WarmGlass.com - Search

Search found 8 matches

Go to advanced search

by Deb Brown
Sat Feb 06, 2016 12:15 pm
Forum: Techniques and Tools
Topic: kiln side elements not working
Replies: 12
Views: 7868

Re: kiln side elements not working

Thanks Tony. I have now successfully replaced my relay, and yayyyyy!!!!! my kiln is now working again. This solution is directly because of the input from this forum, I thank you all with all of my heart!!!
by Deb Brown
Tue Feb 02, 2016 10:27 pm
Forum: Techniques and Tools
Topic: kiln side elements not working
Replies: 12
Views: 7868

Re: kiln side elements not working

Hi Arnold, Brad and Tony - I have used my multimeter ( with care ) and determined that no power is getting to my side elements, and made sure power is coming into the kiln ok. Therefore you are correct that it is the relay that needs replacing. I will order one tomorrow, and am confident I can insta...
by Deb Brown
Tue Feb 02, 2016 5:28 pm
Forum: Techniques and Tools
Topic: kiln side elements not working
Replies: 12
Views: 7868

Re: kiln side elements not working

Thanks Arnold, I have a multimeter. I will open up the kiln electrical again and take a look at everything, see what I can see, test what I can test. :)
by Deb Brown
Tue Feb 02, 2016 5:27 pm
Forum: Techniques and Tools
Topic: kiln side elements not working
Replies: 12
Views: 7868

Re: kiln side elements not working

thanks, input re thermocouple very useful, really appreciate being able to get advise, :)
by Deb Brown
Tue Feb 02, 2016 5:13 pm
Forum: Techniques and Tools
Topic: kiln side elements not working
Replies: 12
Views: 7868

Re: kiln side elements not working

Thank you for your input Tony and Arnold - I will look into replacing the relay(s), this makes sense to me .
by Deb Brown
Tue Feb 02, 2016 12:46 am
Forum: Techniques and Tools
Topic: kiln side elements not working
Replies: 12
Views: 7868

kiln side elements not working

I have an Evenheat Rampmaster II, GTS 23-13. The side elements are not coming on when I fire. The lid element works fine. I just ordered new elements and replaced them, turned kiln on, and grrr, they are still not coming on. I do not understand what is going on, I am stumped, ----anyone with advise ...
by Deb Brown
Fri Nov 22, 2013 11:13 am
Forum: Techniques and Tools
Topic: nichrome wire inclusion
Replies: 6
Views: 4989

Re: nichrome wire inclusion

I use the nichrome wire in fused glass sculptures. I usually use 17 Ga, and sometimes twist several strands together. I have been doing this for years and it works fine 2 out of 3 times. I just dont understand why sometimes it doesnt work. There must be others who use wire and have experience with t...
by Deb Brown
Tue Nov 19, 2013 11:18 am
Forum: Techniques and Tools
Topic: nichrome wire inclusion
Replies: 6
Views: 4989

nichrome wire inclusion

I use Nichrome high temp wire inclusions alot in my fusing. Usually it works fine but sometimes I have trouble with a small crack occurring at the tip of the wire. I have tried slow soaks, slow ramp down, longer anneal soak, thicker glass, everything I can think of. I am frustrated, and wonder if ot...

Go to advanced search

Warm Glass

2575 Old Glory Road, Suite 700
Suite 700
Clemmons, NC 27012
Phone: (336) 712 8003
Email: wg@warmglass.com